The Empire’s Crisis

1 / 8
2 / 8
3 / 8
4 / 8
5 / 8
6 / 8
7 / 8
8 / 8
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$2.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Oct 14, 2019
Languages
German, Spanish, French, English, Italian

Instructions to activate The Empire’s Crisis cd key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate The Empire’s Crisis key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

Description of The Empire’s Crisis steam key free

The Empire’s Crisis cd key free on SteamGateways. FREE steam games. Instant delivery 24/7. FREE steam keys. CD Keys Gift. FREE Codes & Giveaways. Instant download. The Empire’s Crisis key free

The Empire’s Crisis free steam key

The Empire founded by Humanitys greatest hero and sanctioned by the God of Order himself is on the cusp of its worst time of hardship in almost 300 years of history. You play as a previously unknown mercenary who, after being caught up in the Empires time of chaos and misery, may be capable of growing strong enough to close the book on these trying times... or write the next chapter himself. The Empires Crisis is an RPG Maker game that offers: * 12-20 hours of runtime * A character-driven story closely tied to the history and mythology of the world * A main quest that takes the player and their party to the corners of the known world, and back again * Side quests featuring the main Guilds of the land to explore certain regions in more depth * Character progression beyond leveling up, in branching class promotions that make each playthrough a little different * 2 different endings, each of which dramatically changes the course of history
Source: steampowered.com

System requirements
Windows Requirements
  • OS: 64-bit
  • Memory: 4 GB RAM
  • Storage: 3999 MB available space
Mac Requirements
Not available.
Linux Requirements
Not available.