Beardy McStrongarm

1 / 7
2 / 7
3 / 7
4 / 7
5 / 7
6 / 7
7 / 7
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$7.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Mar 16, 2020
Languages
German, Spanish, French, English, Italian

Instructions to activate Beardy McStrongarm steam key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate Beardy McStrongarm key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

Description of Beardy McStrongarm free steam key

Free Beardy McStrongarm steam key. Free steam games. Instant delivery 24/7. Free steam keys. CD Keys Gift. Free Codes & Giveaways. Instant download. Beardy McStrongarm cd key free

Beardy McStrongarm key free

Beardy McStrongarm is an Indie developed 2D Platformer with unique mechanics and challenging game-play. Take on the role of Beardy, a bearded strongman with questionably endless strength in his one arm, joined by his buddy, Jorgy, a purple cat, to travel across the distant lands on an excellent adventure to finally meet Jorgys internet love interest.

Features:
  • Play as Beardy accompanied by Jorgy in a 2D pixel art platformer
  • Unique grappling mechanics for climbing and using item pickups
  • There are cats in the game (Based on a true story)
  • The game is challenging and rewarding for a skilled player
  • Everything in the game is made entirely by one person
  • Spend your time fishing if you want, or not
  • Contains an original soundtrack
  • Some of the cats are warrior cats (In case you were wondering)
  • Dont get too frustrated, take breaks as needed

Are you Strong enough?

Are you Beard enough?
Source: steampowered.com

System requirements
Windows Requirements
  • OS: Windows XP, Vista, 7, 8, or 10
  • Memory: 2 GB RAM
  • Graphics: 128MB
  • Storage: 200 MB available space
Mac Requirements
Not available.
Linux Requirements
Not available.